Troubleshooting Backup Failure: Vembu Guest Tools Installation Requires .NET Framework v3.5

Troubleshooting Backup Failure: Vembu Guest Tools Installation Requires .NET Framework v3.5

KB ID: 501011
Issue:
Backup failed. Vembu Guest tools installation requires .NET Framework v3.5 on the Windows instance enabled with Application-aware or Pre/Post Scripts. Please install .NET Framework and proceed with backup.
Cause:
This problem can occur due to the following reason:
  1. Absence of .NET Framework v3.5 in the Windows instance/VM.
Solution:
To address the problem, consider the following suggestions:
  1. Connect to your backup configured instance/VM and install the .Net Framework v3.5 in it, then restart the instance/VM.
Note: For Azure VMs, before restarting, connect to your Azure portal, uninstall "vembu_guest_tools_application" in "Extensions + Applications" menu, and wait for some time to complete uninstallation. Afterward, restart the VM and proceed with the backup once started.