Troubleshooting: Service Running Without Required Privileges in BDRSuite
Troubleshooting: Service Running Without Required Privileges in BDRSuite Backup Server / BDRSuite Remote Proxy / BDRSuite Agent
KB ID: 117000
Cause
The alert "The service is running in the logon account that does not have the required privileges" occurs when the BDRSuite Backup Server / BDRSuite Remote Proxy / BDRSuite Agent does not have administrator privileges. This privilege is essential for the service logon to install BDRSuite Delegation Service (BDS) for Hyper-V backup and BDRSuite Backup Agent (BBA) for Disk Image and Files & Folders Backup on the target machine.
Solution
To resolve this issue, ensure that the BDRSuite Backup Server / BDRSuite Remote Proxy / BDRSuite Agent is running with either of the following privileges:
1. Administrator
2. User having administrator privilege
Steps to add the Service logon on your BDRSuite Backup Server
Step 1: Go to 'Run' and type "Services.msc".
Step 2: On the Services page, locate the below services
BDRSuite Backup Server for Virtual Physical Workloads
Step 3: Right-click on the concerned service and select Properties, then navigate to the "Logon" tab.
Step 4: Provide your administrator credential details in the "This Account" section.
Step 5: Once user account details are updated, click "Apply" and then "OK".
Step 6: Restart the respective service for the changes to take effect.
For step by step process watch the below video
Steps to add the Service logon on your BDRSuite Remote Proxy
Step 1: Go to 'Run' and type "Services.msc".
Step 2: On the Services page, locate the below services
BDRSuite Remote Proxy Service
Step 3: Right-click on the concerned service and select Properties, then navigate to the "Logon" tab.
Step 4: Provide your administrator credential details in the "This Account" section.
Step 5: Once user account details are updated, click "Apply" and then "OK".
Step 6: Restart the respective service for the changes to take effect.
Steps to add the Service logon on your BDRSuite Agent
Step 1: Go to 'Run' and type "Services.msc".
Step 2: On the Services page, locate the below services
BDRSuite Delegation Service
Step 3: Right-click on the concerned service and select Properties, then navigate to the "Logon" tab.
Step 4: Provide your administrator credential details in the "This Account" section.
Step 5: Once user account details are updated, click "Apply" and then "OK".
Step 6: Restart the respective service for the changes to take effect.
Note: If you encounter any issues during service restart, please verify the user credentials provided during the logon update.
The Remote Proxy in BDRSuite/BDRCloud is a component designed to extend backup and recovery capabilities to remote environments, particularly for backing up virtual machines (VMs), physical servers, or hypervisors that are not directly connected to ...
The Remote Proxy in BDRSuite/BDRCloud is a component designed to extend backup and recovery capabilities to remote environments, particularly for backing up virtual machines (VMs), physical servers, or hypervisors that are not directly connected to ...
KB ID: 115202 Overview This knowledge base article provides step-by-step instructions for manually installing the BDRSuite Backup Agent (BBA) on various host operating systems (Windows, Linux, Mac) to establish connections with the BDRSuite Backup ...
KB ID: 117047 Cause: The error message "Agent version is incompatible with BDRSuite Backup Server" is encountered when there is a version mismatch between the BDRSuite Backup Server and the BDRSuite Integration Service running on Microsoft Windows ...
Prerequisites The VMware ESXi or vCenter Server you want to add should be of Licensed Edition The VMware ESXi or the vCenter Server should be v4.0 & above Adding VMware ESXi/vCenter host Remote Network Step 1: Log in to your backup server machine and ...