Error Fetching Info from WMI Repositories (WMIC) in Agent Machine

Error Fetching Info from WMI Repositories (WMIC) in Agent Machine

KB ID: 115062
Issue:
The following alert message is displayed when attempting to add a Windows agent or upgrade VembuIntegrationService from an older version that is already pushed to a Windows agent:
Error while Fetching Info from WMI repositories (WMIC) in agent machine
Cause:
This alert occurs when BDRSuite is unable to retrieve information about the OS architecture using the WMI service of the Windows agent to be added. It may also happen if the password of the Windows agent contains special characters like ‘ and “.
Possible Solutions:
1. Ensure that the WMI service (service display name: Windows Management Instrumentation, service name: winmgmt) is enabled and running on the Windows agent to be added. 
  1. Open the Windows services console via Run → type "Services.msc."
  2. In services.msc, select "Windows Management Instrumentation."
  3. If the service is disabled, enable and start it.
2. Confirm that the WinRM service is running on both the BDR server host and the Windows agent to be added.   
  1. Open the Windows services console via Run → type "Services.msc."
  2. Search for "Windows Remote Management (WS-Management)" service.
  3. If the service is disabled, enable and start it.
3. Ensure that both the BDR server host and the Windows agent are configured to receive remote PowerShell requests.
  1. Open PowerShell on the Microsoft Windows Server.
  2. Type the following command to enable Remote PowerShell:
     Enable-PSRemoting
  1. Confirm the enabling process.
  2. To check if Remote PowerShell is enabled, enter the following command in PowerShell:
     Enter-PSSession
Enter your computer name or "localhost." If it returns nothing, Remote PowerShell is enabled.