KB ID: 103005
Details:
BDRSuite utilizes its proprietary image backup driver to track block-level changes in the disk designated for backup. When taking incremental backups, a "Backup failed as the source disk order is altered" error may occur if the BDRSuite proprietary driver cannot track block-level changes due to changes in the order of disks configured for the backup.
Causes:
There are two possible reasons for this error:
- The order of disks in the target machine configured for backup is changed during an incremental backup.
- The external storage device(s) attached to the target machine during the backup configuration is disconnected or removed.
Solutions:
In both cases, it is necessary to restore the disk order to its original state. Follow the appropriate steps below to find the original disk order:
If the backup job is configured from the Vembu BDR Backup Server:
Step 1: Open the target machine and navigate to the Vembu Integration Service installation location. By default, it is installed on the OS drive (C-drive on most machines).
Step 2: Open the proxy.log file located at <installation location>\Program Files\Vembu\VembuIntegrationService\log\<backup server ID>\<backup job name>\proxy.log.
Step 3: Search for the lines "Configured Disk No :: X, Current Disk No :: Y."
X: Disk number received during the initial full backup schedule.
Y: Disk number received for the recent incremental schedule.
Step 4: Change the disk order of the target machine to its original state and rerun the backup job.
If the backup job is configured using BDRSuite Client:
Step 1: Open the target machine and navigate to the BDRSuite Client installation location. By default, it is installed on the OS drive (C-drive on most machines).
Step 2: Open the backup.log file located at <installation location>\Program Files\Vembu\VembuImageBackup\log\<backup job name>\backup.log.
Step 3: Search for the lines "Configured Disk No :: X, Current Disk No :: Y."
X: Disk number received during the initial full backup schedule.
Y: Disk number received for the recent incremental schedule.
Step 4: Change the disk order of the target machine to its original state and rerun the backup job.